Comparing characters with umlauts

Runes of Magic/Radiant Arcana (http://www.runesofmagic.com)

Moderators: lisa, rock5

Post Reply
Message
Author
Buh
Posts: 41
Joined: Thu Dec 10, 2015 12:39 am

Comparing characters with umlauts

#1 Post by Buh » Tue Oct 24, 2017 10:54 am

Hey

Im starting by bot(s) with a binary file.
This includes:
START ../micromacro/micromacro.exe ../botscript.lua profile:default character:xxxöüä...
If i have any umlauts in my current opened characters, it will not automatically choose this character to run the bot.

Is it possible now, to change the code (charset of comparison of input and current opened RoM Windows) to let micromacro automatically choose the given characters?

I would be awesome, to get some answers / possible solutions for this issue.

Greetings BUH =)

User avatar
Administrator
Site Admin
Posts: 4861
Joined: Sat Jan 05, 2008 4:21 pm

Re: Comparing characters with umlauts

#2 Post by Administrator » Tue Oct 24, 2017 12:25 pm

I believe we convert the umlaut characters to the closest non-umlaut character equivalent. That is, ü becomes u, ä becomes a, and so on.

So if your character name was Böb, just use a profile named bob.xml. I'm not sure which characters are converted; I think ß might convert to ss (as opposed to sz).

Buh
Posts: 41
Joined: Thu Dec 10, 2015 12:39 am

Re: Comparing characters with umlauts

#3 Post by Buh » Thu Nov 09, 2017 12:06 pm

Hey

this doesnt work..

I mean also : im starting the bot in a batch file and directly assign the Character names to the RoM Clients.

So is there another way to compare that given Character names from the opened clients on the one hand and on the other hand the assigned character names in the bat file?

Greetings

User avatar
Administrator
Site Admin
Posts: 4861
Joined: Sat Jan 05, 2008 4:21 pm

Re: Comparing characters with umlauts

#4 Post by Administrator » Fri Nov 10, 2017 12:35 am

Could you PM me your character name? Please do not post it publicly for your item protection.

I might have to dig up the code after not touching it in years so I can figure out what's going wrong.

Buh
Posts: 41
Joined: Thu Dec 10, 2015 12:39 am

Re: Comparing characters with umlauts

#5 Post by Buh » Fri Nov 10, 2017 11:04 am

i wont tell my char name

But it probably can be "Swüßé"

User avatar
Administrator
Site Admin
Posts: 4861
Joined: Sat Jan 05, 2008 4:21 pm

Re: Comparing characters with umlauts

#6 Post by Administrator » Sat Nov 11, 2017 11:25 pm

Looks like in database/utf8_ascii.xml, there are replacements for those characters. For example:

Code: Select all

<utf8_ascii utf8_1="195" utf8_2="159" ascii="225" dos_replace="ss" /> // ß
<utf8_ascii utf8_1="195" utf8_2="188" ascii="129" dos_replace="ue" /> // ü
<utf8_ascii utf8_1="195" utf8_2="169" ascii="130" dos_replace="e" /> // é
Not entirely sure why ü is converted to "ue" instead of just "u," but whatever. Maybe that's the cause of the problem? Try adding that 'e' into your character's name in the command-line argument.

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 6 guests