Search found 4427 matches

by Administrator
Mon Apr 04, 2022 9:38 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

dr-nuker wrote: Sun Apr 03, 2022 8:20 am since some months rom bot takes ages for me to load and once it is loaded, it does not do anything :(
Which game version are you running? Have you done a full update by downloading the full, latest package here and overwriting all your files?
by Administrator
Sat Apr 02, 2022 8:45 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

I haven't been able to reproduce this issue.

Has anyone else had issues with this script?
by Administrator
Sat Apr 02, 2022 8:33 am
Forum: Runes of Magic
Topic: Problem with "when finished"
Replies: 3
Views: 329

Re: Problem with "when finished"

You have to provide the exact code you're using, and also the exact error message.
by Administrator
Sat Mar 26, 2022 8:37 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

nuk79: The error about the update of CItem id <whatever> is probably safe to ignore. It looks like the real problem is that something is trying to use a variable called sstime . There's nothing in the standard scripts that has a variable named that so it might be coming from one of your profiles, us...
by Administrator
Thu Mar 24, 2022 7:40 pm
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

I just merged fixes for client version 7.4.0.2969, which serves to update a number of memory addresses. PR is here: https://github.com/SolarStrike-Software/rom-bot/pull/7/files You guys should be able to run the rom-bot/gitupdate script, or run rombot_updater.exe from the rom-bot script directory to...
by Administrator
Sat Mar 19, 2022 9:05 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

Just loaded things up and still see the same version number and all of the addresses seem in-tact.

Is there something that isn't working for you?
by Administrator
Sat Mar 19, 2022 8:58 am
Forum: Runes of Magic
Topic: Hilfe beim Makro
Replies: 3
Views: 365

Re: Hilfe beim Makro

Here's a tutorial on how to create an addon:

https://runesofmagic.fandom.com/wiki/Addon_Tutorial


I think you want to create a "slash command" that can then cast all of the skills you need.
by Administrator
Sat Mar 19, 2022 8:46 am
Forum: RoM general
Topic: Registering Lua Functions
Replies: 1
Views: 311

Re: Registering Lua Functions

This does indeed seem like a pretty cool project you've got going here.
Have you also been able to register C functions?
by Administrator
Sun Mar 13, 2022 8:17 am
Forum: Runes of Magic
Topic: Hilfe beim Makro
Replies: 3
Views: 365

Re: Hilfe beim Makro

I believe that RoM's code was changed years ago to support only allowing a single "action" (a skill in this case) to trigger from a single macro.

I think you would need to create an addon instead, but I'm not sure if that would actually solve it.
by Administrator
Sun Mar 13, 2022 8:15 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

Unfortunately that error doesn't really describe what went wrong. Is there a specific time that it errors out, or is the bot doing a specific thing?
by Administrator
Sun Mar 06, 2022 10:45 am
Forum: RoM general
Topic: WorldToScreen
Replies: 2
Views: 261

Re: WorldToScreen

I took a quick look at the Runes of Magic API. Doesn't look like there's a Lua-exposed function for this, unless I'm mistaken. That of course makes it a little bit more difficult if the function is only in the C API. If you're able to get the camera/view matrix details and such you could write your ...
by Administrator
Sun Mar 06, 2022 10:04 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

I noticed one thing: <skill name="DRUID_MOTHER_EARTH'S_FOUNTAIN" hotkey="MACRO" priority="100" /> There's a single quote ( ' ) in there. In database/skills.xml it is listed without the quote: DRUID_MOTHER_EARTHS_PROTECTION . Try fixing the name and see if that helps. Yo...
by Administrator
Sat Feb 26, 2022 9:40 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

That's weird... I wonder if it is related to the anti-killsteal code, maybe?

Could you try changing the ANTI_KS option to false in your profiles for both players?

Code: Select all

<option name="ANTI_KS"            	value="false" />
by Administrator
Tue Feb 22, 2022 6:02 pm
Forum: Runes of Magic
Topic: Warrior/Mage (warmage) elite 60 is still not working!
Replies: 12
Views: 974

Re: Warrior/Mage (warmage) elite 60 is still not working!

I've made the correction. Thank you for the report.
by Administrator
Tue Feb 22, 2022 1:27 pm
Forum: Runes of Magic
Topic: Warrior/Mage (warmage) elite 60 is still not working!
Replies: 12
Views: 974

Re: Warrior/Mage (warmage) elite 60 is still not working!

I've updated the skill ID in database/skills.lua in the latest copy of the scripts; updates from here on out will include that fix. You should be able to remove the DEBUG_SKILLUSE option from your profile now to cut down on how spammy it is. As for the second issue, the stacktrace at the bottom of y...
by Administrator
Tue Feb 22, 2022 7:31 am
Forum: Runes of Magic
Topic: Version 7.4.0.2897 progress
Replies: 1056
Views: 213370

Re: Version 7.4.0.2897 progress

Hail. The first post is about Version 7.4.0.2897 progress. The file in the first post is working on last patch ? Current Patch 7.4.0.2967. Sorry for my english toung and i'm causal gamer, and causal user of micromacro. Yes. That link always points to the latest version of the scripts, whatever it i...
by Administrator
Sun Feb 20, 2022 8:39 am
Forum: Runes of Magic
Topic: Warrior/Mage (warmage) elite 60 is still not working!
Replies: 12
Views: 974

Re: Warrior/Mage (warmage) elite 60 is still not working!

OK, so... I think you should leave autouse to true (or just leave that off the skill entirely). Set the correct skill ID and buffname (IDs) in skills.xml like you've done. Next, get rid of the onPreSkillCast stuff entirely -- I think what's happening here is that onPreSkillCast tries to cast the ski...
by Administrator
Sat Feb 19, 2022 3:11 pm
Forum: Runes of Magic
Topic: Warrior/Mage (warmage) elite 60 is still not working!
Replies: 12
Views: 974

Re: Warrior/Mage (warmage) elite 60 is still not working!

EDIT: Found the problem. There was a a minor change made to the skillbook's skill struct. An additional 4 bytes have been added to this struct, so addresses.skillbook.skill.size changed from 0x48 to 0x4C. If you run the rombotupdater again, or manually update the skill size in your addresses.lua, th...
by Administrator
Sat Feb 19, 2022 8:42 am
Forum: Runes of Magic
Topic: Warrior/Mage (warmage) elite 60 is still not working!
Replies: 12
Views: 974

Re: Warrior/Mage (warmage) elite 60 is still not working!

Could you post what the onPreSkillCast workaround was? That might help determine exactly what's going on. I would also recommend that you temporarily remove all the skills from your profile's warrior section except for Lightning Burn Weapon, and also add: <option name="DEBUG_SKILLUSE" valu...
by Administrator
Fri Feb 18, 2022 5:08 pm
Forum: Runes of Magic
Topic: Time-Function
Replies: 2
Views: 345

Re: Time-Function

You can probably handle that with a bit of trickery in your waypoints. For example, something like this: <?xml version="1.0" encoding="utf-8"?> <waypoints> <!-- Put this at the top of your waypoints script --> <onLoad><![CDATA[ last_npc_visit = os.time() visit_npc_minutes = 60 fu...