Search found 54 matches

by Zephyr
Tue Dec 16, 2008 10:11 pm
Forum: Runes of Magic
Topic: RoM bot
Replies: 2213
Views: 326781

Re: RoM bot

made a tweak myself. Since depending on lag or mob it seems to put me on top of the mob at 5. I believe I did it right, it does seem to work. set it so that it pulls the distance from my profile xml file. original elseif( settings.profile.options.COMBAT_TYPE == "melee" ) then -- Run right at them an...
by Zephyr
Mon Dec 15, 2008 10:50 pm
Forum: Runes of Magic
Topic: RoM bot
Replies: 2213
Views: 326781

Re: RoM bot

My typo in the Skills.xml under mage. The second 14 should be a 15. <skill name="MAGE_GALAXY_13" mana="77" range="150" type="damage" target="enemy" /> <skill name="MAGE_GALAXY_14" mana="80" range="150" type="damage" target="enemy" /> <skill name="MAGE_GALAXY_14" mana="84" range="150" type="damage" t...
by Zephyr
Fri Nov 21, 2008 9:15 pm
Forum: Runes of Magic
Topic: [Help] Runes Of Magic
Replies: 29
Views: 4516

Re: [Help] Runes Of Magic

OK, with CE working was able to track down pointers and offsets

pointer
014fe124

hp
0x314

energy/mana(primary class bar)
0x320

energy/mana(secondary class bar)
0x328



gonna work on target next.
by Zephyr
Fri Nov 21, 2008 6:01 pm
Forum: Off topic
Topic: Protection Error 103
Replies: 3
Views: 851

Re: Protection Error 103

Well could not track done what was causing this. But my best guess was something with MS Windows. Did a format and reinstall and all is fine.

I did try all the security steps to make sure and none worked.

The method i was using to attach was by finding an address then seeing what accesses it
by Zephyr
Sun Nov 02, 2008 8:31 pm
Forum: Off topic
Topic: Protection Error 103
Replies: 3
Views: 851

Protection Error 103

Copied from another thread to not take it over. Orig. post Started looking at this one myself. I get down to four addresses. When I check to see what is accessing one to find the pointer I get a Proction error 103 msg dialog. The odd thing is I receive the same exact dialog with Perfect World. Has a...
by Zephyr
Sun Nov 02, 2008 7:07 pm
Forum: Runes of Magic
Topic: [Help] Runes Of Magic
Replies: 29
Views: 4516

Re: [Help] Runes Of Magic

Started looking at this one myself. I get down to four addresses. When I check to see what is accessing one to find the pointer I get a Proction error 103 msg dialog. The odd thing is I receive the same exact dialog with Perfect World. Has anyone come across this one? Been disabling AV and other pro...
by Zephyr
Sun Oct 19, 2008 7:36 pm
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

just got my internet back. was working on this a little before i moved. vvayinsane did you have any issues with finding static pointers? for some reason the game would give a protection error then close. So I was thinking there is some kind of protection now.
by Zephyr
Thu Apr 24, 2008 7:10 pm
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

Log into PW and open micromacro.exe Run the script pw.lua Select your profile (and window, if multi-client) Create a monster list Start the bot Just to make sure, you did the steps listed above? One other item to check, make sure you have your F Lock on. I know there are some keyboards that have th...
by Zephyr
Wed Apr 23, 2008 10:53 am
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

the targetid_offset is off

here are my settings that work for me.

staticbase_ptr = 0x00903804;
staticbase_offset = 0x20;
charptr_addr = 0;
targetid_offset = 0xa18;

HP_offset = 1104;
MaxHP_offset = 1144;
MP_offset = 1108;
MaxMP_offset = 1148;
by Zephyr
Wed Apr 23, 2008 1:51 am
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

I checked myself one more time. I even tried on the actual server and not the private one doing all the same steps. And I was able to get it to work. So might be something with the modded exe they used. kev2000, for the actual server hosted by cubizone the address should look like so. staticbase_ptr...
by Zephyr
Mon Apr 21, 2008 11:03 pm
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

Well played with it some more tonight. seems my pointers are right. offsets seem to be the same again too. I have tried magic and a ranged class with combo skills here is what I have so far. staticbase_ptr = 0x0325BC88; staticbase_offset = 0x20; charptr_addr = 0; -- no idea if this is suppose to cha...
by Zephyr
Sun Apr 20, 2008 7:57 pm
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

Elverion Any suggestions on finding the offset for the target ID? I tried both Artmoney and CheatEngine. What I found was 0xA08(w/ CE) & 2565(w/ AM). The script will not target, but does show an address being added to the monster list. If manual targeting is used the script will attack only. I am go...
by Zephyr
Sat Apr 19, 2008 7:33 pm
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

Thanks Elverion That was actually fairly simple. Only took about 5 mins to do. The staticbase_ptr ended up being 0x0325BC88. It was the second step I was missing. As for the offsets, they are the same. Thanks Again Zeph *Edit: Spoke a little soon. Seems targetid is different. So now just working on ...
by Zephyr
Fri Apr 18, 2008 8:14 pm
Forum: MicroMacro scripts
Topic: Perfect World bot & multi-client
Replies: 53
Views: 7707

Re: Perfect World bot & multi-client

elverion I am trying to change the staticbase_ptr = in the pw.lua file so that i can try this on a private server. Using Art-Money I found 0325BCA8 as the pointer. Is this all I need or is there more information that I need to look for? I just want to make sure, was reading the MPC forums and notice...