Version 7.4.0.2897 progress

Runes of Magic/Radiant Arcana (http://www.runesofmagic.com)
Message
Author
User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#781 Post by Administrator » Sat Oct 10, 2020 5:30 pm

I spent a few hours today on a small tool that will speed up this update process. Usually the memdatabase stuff is a huge pain in the butt to find the new address for. That's just a side-effect of it's branching complexity.

The new tool will attempt to brute-force the memdatabase base address. Previously I had just written a simpler version directly in the RoMScripts and it was incredibly slow and failed to turn up any meaningful results within a timeframe that I would consider useful. The new version is slimed-down and makes use of multi-threading to process attempts like a champ; much faster and more efficient.

Point is, it's going well thus far. I'm going to deploy this onto my workhorse 3950x at 32 threads, ~128GB RAM and see what happens. If it works without issue, then I may provide it in the future so that all of you can also pitch it the effort and we can use distributed processing to find it even faster in the future.
Attachments
MDBrute. Not much to look at, but should be useful!
MDBrute. Not much to look at, but should be useful!

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#782 Post by nuk79 » Sun Oct 11, 2020 3:43 am

Is it possible that every time they patch the game the addresses and all the ip already included in the package of events they do every year change? Let me explain, every year they do the usual events, you should make a comparison of the addresses of the year before with that of the following year or maybe just some other ids

Andre235
Posts: 153
Joined: Thu Oct 03, 2019 4:08 am

Re: Version 7.4.0.2897 progress

#783 Post by Andre235 » Sun Oct 11, 2020 4:02 am

the addresses will be increased by every patch. so we will never get the same addresses at the same event... but it is possible, that the addresses will have the same address difference than the event in the last year. this coud help, if you will find the addresses manually. i think that its not the right way to update the addresses automatically...

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#784 Post by nuk79 » Sun Oct 11, 2020 7:18 am

i don't know how to do this ..i ask many times and i donìt know know to follow the posts for learn...i need to someone explain me how to do

Add prediction for block 510000, branch 0x70
Add prediction for block 521000, branch 0x260
Add prediction for block 212000, branch 0x2A0
Add prediction for block 213000, branch 0x2A4
0-10-11 14:58:38 - C:/Program Files/micromacro/scripts/rom/classes/item.lua:154: attempt to concatenate field 'Name' (a nil value)

tristanlol
Posts: 16
Joined: Sun Dec 29, 2019 5:59 pm

Re: Version 7.4.0.2897 progress

#785 Post by tristanlol » Sun Oct 11, 2020 9:24 am

I think there is currently a problem with game texts. Cached texts file is almost empty (only with game version) and so, it fails when talking with an npc for example.

Waiting for the new brute-force tool results :P

Thanks!

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#786 Post by Administrator » Sun Oct 11, 2020 10:18 am

tristanlol wrote: Sun Oct 11, 2020 9:24 amWaiting for the new brute-force tool results :P
The results are in! This morning I had to make a few more corrections and refinements, and very happy with the results. Within a matter of minutes it turned up two addresses:
0x631b44
0x631b48

If you plug that in for addresses.memdatabase.base, it would seem the bot now can find items in memory correctly, so it looks like my new tool is working. Running a program and waiting for results in a few minutes sure beats manually digging through memory trees for 2 days...

There's still work to be done in other areas, but this is the major one that needed fixing.


Project source code available at: https://github.com/SolarStrike-Software/mdbrute
Release (binary) download available at: https://github.com/SolarStrike-Software ... /releases/

Andre235
Posts: 153
Joined: Thu Oct 03, 2019 4:08 am

Re: Version 7.4.0.2897 progress

#787 Post by Andre235 » Sun Oct 11, 2020 1:38 pm

Administrator wrote: Sun Oct 11, 2020 10:18 am
tristanlol wrote: Sun Oct 11, 2020 9:24 amWaiting for the new brute-force tool results :P
The results are in! This morning I had to make a few more corrections and refinements, and very happy with the results. Within a matter of minutes it turned up two addresses:
0x631b44
0x631b48

If you plug that in for addresses.memdatabase.base, it would seem the bot now can find items in memory correctly, so it looks like my new tool is working. Running a program and waiting for results in a few minutes sure beats manually digging through memory trees for 2 days...

There's still work to be done in other areas, but this is the major one that needed fixing.


Project source code available at: https://github.com/SolarStrike-Software/mdbrute
Release (binary) download available at: https://github.com/SolarStrike-Software ... /releases/
i got the same results:
0x00631b44
0x00631b48

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#788 Post by Administrator » Sun Oct 11, 2020 2:10 pm

I just merged some of my changes into the master branch. You guys can now update with git and should have most features working.

tristanlol
Posts: 16
Joined: Sun Dec 29, 2019 5:59 pm

Re: Version 7.4.0.2897 progress

#789 Post by tristanlol » Sun Oct 11, 2020 5:09 pm

Great news!

It's now working again.

Thanks!

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#790 Post by nuk79 » Sun Oct 11, 2020 5:43 pm

attempt to perform arithmetic on field 'pawnId_offset' (a nil value)
i have this error now

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#791 Post by Administrator » Sun Oct 11, 2020 5:51 pm

nuk79 wrote: Sun Oct 11, 2020 5:43 pm attempt to perform arithmetic on field 'pawnId_offset' (a nil value)
i have this error now
Post the whole error message. Without the traceback it's next to impossible to tell what's wrong.

It would also help if you explained exactly what you were trying to do, and what was going on right before/during this error.

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#792 Post by nuk79 » Tue Oct 13, 2020 9:47 am

Administrator wrote: Sun Oct 11, 2020 5:51 pm
nuk79 wrote: Sun Oct 11, 2020 5:43 pm attempt to perform arithmetic on field 'pawnId_offset' (a nil value)
i have this error now
Post the whole error message. Without the traceback it's next to impossible to tell what's wrong.

It would also help if you explained exactly what you were trying to do, and what was going on right before/during this error.
pumpkin festival minigame
Attachments
Yolius_onload.lua
(11.24 KiB) Downloaded 23 times
Yolius.xml
(4.1 KiB) Downloaded 18 times

Onche
Posts: 52
Joined: Thu Jun 11, 2015 6:10 pm

Re: Version 7.4.0.2897 progress

#793 Post by Onche » Tue Oct 13, 2020 10:39 am

nuk79 wrote: Tue Oct 13, 2020 9:47 am
Administrator wrote: Sun Oct 11, 2020 5:51 pm
nuk79 wrote: Sun Oct 11, 2020 5:43 pm attempt to perform arithmetic on field 'pawnId_offset' (a nil value)
i have this error now
Post the whole error message. Without the traceback it's next to impossible to tell what's wrong.

It would also help if you explained exactly what you were trying to do, and what was going on right before/during this error.
pumpkin festival minigame
That's because pawnId_offset is the old name of the address. I took a more recent version of the script and changed all the adresses inside with the new names, can you please try to use it and tell me if it works ?

But please be careful as the script makes your char fly and teleport inside the minigame, which is highly detectable by GMs (which is why I didn't try myself).

If anyone know how to update the haunted scripts so the char doesn't fly/teleport and just walk, I would be thanful. I tried to avoid that teleporting stuff by replacing "teleport(" with "player:moveTo(", but the script just breaks when the minigame starts when trying to click on a tile... I guess it has something to do with the clicktile(tile) function in Haunted_onload.lua but I have no idea what is wrong inside...
Attachments
Haunted.xml
(5.38 KiB) Downloaded 21 times
Haunted_onload.lua
Changed the name of the addresses with the new ones / Uses Fly and Teleport functions
(13.55 KiB) Downloaded 18 times

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#794 Post by nuk79 » Thu Oct 15, 2020 10:41 am

many years ago i delete a string inside .xml or lua...player not fly but trasnport fast......i try to delete "Fly()" function but when inside at start him use swimhack....i don't know how to disable this functiuon on lua...can you help me ?

Onche
Posts: 52
Joined: Thu Jun 11, 2015 6:10 pm

Re: Version 7.4.0.2897 progress

#795 Post by Onche » Thu Oct 15, 2020 12:33 pm

nuk79 wrote: Thu Oct 15, 2020 10:41 am many years ago i delete a string inside .xml or lua...player not fly but trasnport fast......i try to delete "Fly()" function but when inside at start him use swimhack....i don't know how to disable this functiuon on lua...can you help me ?
Does the script work properly even if your char is flying ?

To remove the flying part :

1. In the Haunted.xml you need to remove the fly on line 108

Code: Select all

		logentry = "Ran out of time" -- default

		--fly()

		LastTileDug = 0
2. You need to remove this specific line 339 in the Haunted_onload.lua I think :

Code: Select all

function moveto(pos)
	-- if fly then fly() end
	player:updateXYZ()
	if distance(player, pos) > 10 then
		if teleport then
			player:moveTo(pos.X+1,pos.Z+1,18)
		else
			player:moveTo(pos,true)
		end
	end
	player:update()
	player:waitTillStopMoving()
end
Still, you char is teleporting and that is something GMs can detect easily, I would not really try playing around with this.
Still didn't manage to make it work by walking only, bot just crashes so I can't help much more.

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#796 Post by Administrator » Thu Oct 15, 2020 1:10 pm

Still didn't manage to make it work by walking only, bot just crashes so I can't help much more.
Could you give me some details to work off of?

Alcorne
Posts: 3
Joined: Sun May 31, 2015 2:13 am

Re: Version 7.4.0.2897 progress

#797 Post by Alcorne » Thu Oct 15, 2020 2:24 pm

Administrator wrote: Sun Sep 06, 2020 3:13 pm
Alcorne wrote: Sat Sep 05, 2020 2:36 pm
Administrator wrote: Sat Sep 05, 2020 1:43 pm

I'm not able to reproduce that. When did this start happening for you?

Just yesterday, right after I downloaded the new version and ran the github thing.
Try redownloading a fresh copy (use the link from the first post in this thread), overwrite all of your own files. Do not run any other updates. Does it still have the same problem?
Sorry it took so long to test, but yes I get the exact result after downloading fresh

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#798 Post by Administrator » Thu Oct 15, 2020 8:31 pm

Alcorne wrote: Thu Oct 15, 2020 2:24 pm
Administrator wrote: Sun Sep 06, 2020 3:13 pm
Alcorne wrote: Sat Sep 05, 2020 2:36 pm


Just yesterday, right after I downloaded the new version and ran the github thing.
Try redownloading a fresh copy (use the link from the first post in this thread), overwrite all of your own files. Do not run any other updates. Does it still have the same problem?
Sorry it took so long to test, but yes I get the exact result after downloading fresh
You're not running that Gamers4Life 64-bit client, are you?

Assuming you're not using a nonstandard client (only the Gameforge client is supported), the game was just updated and you'll need to do another script update and retest. Copy/paste the error again if it occurs.

Onche
Posts: 52
Joined: Thu Jun 11, 2015 6:10 pm

Re: Version 7.4.0.2897 progress

#799 Post by Onche » Fri Oct 16, 2020 3:35 am

Administrator wrote: Thu Oct 15, 2020 1:10 pm
Still didn't manage to make it work by walking only, bot just crashes so I can't help much more.
Could you give me some details to work off of?
Well yes, I'll give as much details as I can to make it clear for you.

So I took the scripts from this post, and tried to update it because :
- It was made with the old rom bot version so addresses names are outdated,
- The script is making the char to fly (easily detectable by GMs),
- The script is making the char to teleport (easily detectable by GMs),

Now what I did in the scripts (I'm writing everything here but I did write all the changes in the scripts) :

Haunted.xml
1. I just removed the call to fly function

Code: Select all

		--fly()
		--Remove the flying part from the script
Haunted_onload.lua
1. Started by changing all the wrong addresses names, for example :

Code: Select all

return memoryReadRepeat("float", getProc(), pawn.Address + addresses.game_root.pawn.fading) ~= 0 -- was addresses.pawnFading_offset
2. Replaced each call to teleport with a player:moveTo function, for example:

Code: Select all

--teleport(player.X,player.Z,flyheight)
player:moveTo(player.X,player.Z,flyheight)
(by the way, I did not remove flyheight, but just changed its value to 9, which is the ground level, that way I'm not modifying the script a lot)

3. Removed some part of the function moveto(pos) which was calling to teleport AND fly :


NOW THE RESULTS !


So basically when the scripts starts, it crashes on waypoint #6

Code: Select all

Digging up tiles...
Clicking Tile 22
The game client did not crash.
Character: XXXXXXXXXXXX
2020-10-16 10:23:08 - .../MicroMacro/scripts/rom/classes/player.lua:2882: attempt to call method 'update' (a nil value)
I think the issue has something to do with the function moveto(pos) because I removed some lines from it and If I don't, then the script works but my char teleports (didn't pay more attention and stopped the bot when I saw my char teleporting)

Code: Select all

function moveto(pos)
	-- Remove the fly function from the script
	-- if fly then fly() end
	player:updateXYZ()
	if distance(player, pos) > 10 then
		-- If I don't remove this part below, then the script works but the char teleports.
		 --if teleport then
			-- teleport(pos.X+1,pos.Z+1,18)
		 --else
			player:moveTo(pos,true)
		 --end
	end
	player:update()
	player:waitTillStopMoving()
end
The code looks quite simple, yet nothing seems to work, I tried to remove some parts, tried to change teleport( with player:moveTo in that function but then I get : MicroMacro/scripts/rom/classes/player.lua:2604: attempt to index local 'waypoint' (a number value).

Attached you'll find the current modified files.

Thanks !
Attachments
Haunted_onload.lua
(14.08 KiB) Downloaded 20 times
Haunted.xml
(5.42 KiB) Downloaded 19 times

Andre235
Posts: 153
Joined: Thu Oct 03, 2019 4:08 am

Re: Version 7.4.0.2897 progress

#800 Post by Andre235 » Sat Oct 17, 2020 10:36 am

I still have some citem warnings. Sometimes with the Item ids from itemshop bag and sometimes With wrong id values (1 or 501 or Maybe 12xxx, but no 6 digits).

Post Reply

Who is online

Users browsing this forum: No registered users and 19 guests