Version 7.4.0.2897 progress

Runes of Magic/Radiant Arcana (http://www.runesofmagic.com)
Message
Author
User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#741 Post by Administrator » Sun Aug 23, 2020 2:15 pm

For that memdatabase error, it looks like the problem is with whatever function made a call to CMemDatabase:getAddress(). Once this error happens, a stacktrace should be added to log.txt which contains additional information that is not printed to the console window. If you can get it to happen again, could you open up log.txt and copy/paste the error for me?
Tintenkiller96 wrote: Sat Aug 22, 2020 7:38 pm Hi,

does someone has a problem with player:object()?

I get the error no Element found

for example for Helping Growth player:object(112976) when staying close the cleaning cristal
player:object is not a method. Did you perhaps mean player:target_Object()? My best guess is the evaluation function/closure. Maybe try:

Code: Select all

player:target_Object(112976, 1, false, false, false);
Alternatively, you can try:

Code: Select all

player:target_NPC(112976);

Tintenkiller96
Posts: 23
Joined: Thu Sep 24, 2015 3:09 pm

Re: Version 7.4.0.2897 progress

#742 Post by Tintenkiller96 » Wed Aug 26, 2020 12:27 pm

Hi,

exactly im using this function but the result is that he can not find the Crystal for Cleaning while staying near it

queststate = getQuestStatus("Wachstumshilfe")
if queststate == "incomplete" then
player:target_Object(112976,500);
yrest(3000);
__WPL:setWaypointIndex(__WPL:findWaypointTag("Item"));
end

that is my code at the waypoint when he is near the crystal
I also tried
on load just the player:target_Object(112976,500); function and he still says target not found.

Andre235
Posts: 153
Joined: Thu Oct 03, 2019 4:08 am

Re: Version 7.4.0.2897 progress

#743 Post by Andre235 » Wed Aug 26, 2020 3:47 pm

Is it the right id????

Try

Code: Select all

player:target_Object(112976)
yrest(500);
Or

Code: Select all


player:target_Object(112976)
yrest(500);
Attack()
Or harvest it?

Code: Select all

player:harvest(112976);

I looked in the runes database. There is the id 112976 an NPC!!!!

Code: Select all

player:target_NPC(112976)
yrest(500)(
Try try try :oops:

Tintenkiller96
Posts: 23
Joined: Thu Sep 24, 2015 3:09 pm

Re: Version 7.4.0.2897 progress

#744 Post by Tintenkiller96 » Thu Aug 27, 2020 7:46 am

Oh, i see thats explains a lot :D but i used the Get_Object_Id.bat with the mouseover thats why I felt pretty safe about the ID for this Object.

And now I understand why NPC ;) even when using the OBJECT ID reader :D Big thanks!!

Layer 8 Problem nothing wrong about the bot at my point!!!

Okay too early to celebrate :D But hope its just a fail by me.
I tried all the possibilities you mentionted at the spott but the error is: "error closing parser: no element found"
<onLoad>
player:target_Object(112976);
player:target_NPC(112976);
player:harvest(112976);
yrest(500)
</onLoad>
Last edited by Tintenkiller96 on Thu Aug 27, 2020 3:32 pm, edited 1 time in total.

Andre235
Posts: 153
Joined: Thu Oct 03, 2019 4:08 am

Re: Version 7.4.0.2897 progress

#745 Post by Andre235 » Thu Aug 27, 2020 3:27 pm

Please try only one of this options. If you get an error, you can’t be sure, wich of the three lines causes the error...

In my opinion the

Code: Select all

player:target_NPC(112976)
Should work. But you have to write the right name of this function (you wrote:

Code: Select all

player:NPC(112976)
That is maybe the Reason for your latest error...)

Tintenkiller96
Posts: 23
Joined: Thu Sep 24, 2015 3:09 pm

Re: Version 7.4.0.2897 progress

#746 Post by Tintenkiller96 » Thu Aug 27, 2020 3:33 pm

I just did it for you to see which one i used i tried them one by one. Copy Pasta is not always a good option but i had the right one in the code.


FIXED bad coding by me.

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#747 Post by Administrator » Mon Aug 31, 2020 11:37 am

I added some code the other day that should stabilize the camera while botting. That is, the camera should not zoom out really far when fighting enemies. Can anyone confirm that is working well for them, or whether new problems have arisen from this change? How about click-to-cast skills (such as Thunderstorm); do those work better now?

User avatar
ThulsaDoom
Posts: 99
Joined: Mon Oct 19, 2015 2:46 pm

Re: Version 7.4.0.2897 progress

#748 Post by ThulsaDoom » Tue Sep 01, 2020 7:53 am

Administrator wrote: Mon Aug 31, 2020 11:37 am I added some code the other day that should stabilize the camera while botting. That is, the camera should not zoom out really far when fighting enemies. Can anyone confirm that is working well for them, or whether new problems have arisen from this change? How about click-to-cast skills (such as Thunderstorm); do those work better now?
Thank you for continuing to work on improving RoMBot.

Regarding click to cast skills, the same problem continues, the area is located where the cursor is.
If the mouse cursor is outside the window where the client is running, you don't get the desired effect.
Suggestion: place the area and the execution click on the position of the first enemy detected.

Concenrning camera position, when following a waypoint, when there is a slope on the road, the camera is placed just above the character, and it is not placed in the good position until we find a climb on the road.

Alcorne
Posts: 3
Joined: Sun May 31, 2015 2:13 am

Re: Version 7.4.0.2897 progress

#749 Post by Alcorne » Fri Sep 04, 2020 2:57 pm

Im getting an error when starting the bot:

Code: Select all

 functions.lua:2664: bad argument #1 to 'memoryReadIntPtr' ((null))

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#750 Post by Administrator » Sat Sep 05, 2020 1:43 pm

Alcorne wrote: Fri Sep 04, 2020 2:57 pm Im getting an error when starting the bot:

Code: Select all

 functions.lua:2664: bad argument #1 to 'memoryReadIntPtr' ((null))
I'm not able to reproduce that. When did this start happening for you?

Alcorne
Posts: 3
Joined: Sun May 31, 2015 2:13 am

Re: Version 7.4.0.2897 progress

#751 Post by Alcorne » Sat Sep 05, 2020 2:36 pm

Administrator wrote: Sat Sep 05, 2020 1:43 pm
Alcorne wrote: Fri Sep 04, 2020 2:57 pm Im getting an error when starting the bot:

Code: Select all

 functions.lua:2664: bad argument #1 to 'memoryReadIntPtr' ((null))
I'm not able to reproduce that. When did this start happening for you?

Just yesterday, right after I downloaded the new version and ran the github thing.

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#752 Post by Administrator » Sun Sep 06, 2020 3:13 pm

Alcorne wrote: Sat Sep 05, 2020 2:36 pm
Administrator wrote: Sat Sep 05, 2020 1:43 pm
Alcorne wrote: Fri Sep 04, 2020 2:57 pm Im getting an error when starting the bot:

Code: Select all

 functions.lua:2664: bad argument #1 to 'memoryReadIntPtr' ((null))
I'm not able to reproduce that. When did this start happening for you?

Just yesterday, right after I downloaded the new version and ran the github thing.
Try redownloading a fresh copy (use the link from the first post in this thread), overwrite all of your own files. Do not run any other updates. Does it still have the same problem?

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#753 Post by nuk79 » Sun Sep 20, 2020 9:28 am

can someone help witrh this error?
2020-09-20 16:27:23 - [string "..."]:65: attempt to perform arithmetic on field 'charPtrMounted_offset' (a nil value)

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#754 Post by Administrator » Sun Sep 20, 2020 9:35 am

Looks like that error came out of one of the waypoints that you're using, but that address was removed/renamed. Post a copy of it.

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#755 Post by nuk79 » Sun Sep 20, 2020 10:02 am

i can't cause i don't have permission for this
Attachments
JuiceDelivery.xml
(6.98 KiB) Downloaded 22 times

silentz
Posts: 13
Joined: Thu Jun 04, 2009 5:49 pm

Re: Version 7.4.0.2897 progress

#756 Post by silentz » Tue Sep 22, 2020 4:37 am

Admin, can you look into this skill?

Warrior/Mage - WARRIOR_LIGHTNING_BURN_WEAPON

I have it in my profile and it would not cast this skill and doesn't say any error as if the skill is not there.



Thanks

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#757 Post by nuk79 » Thu Sep 24, 2020 8:33 am

in new micromacro we have devtolls interface where inside we have d303 folder.this folder need to be copy in interface folder in rom folder but when you start game you have always item's shop windows open...someone know how to fix it?

User avatar
ThulsaDoom
Posts: 99
Joined: Mon Oct 19, 2015 2:46 pm

Re: Version 7.4.0.2897 progress

#758 Post by ThulsaDoom » Thu Sep 24, 2020 9:45 am

nuk79 wrote: Thu Sep 24, 2020 8:33 am in new micromacro we have devtolls interface where inside we have d303 folder.this folder need to be copy in interface folder in rom folder but when you start game you have always item's shop windows open...someone know how to fix it?
Please, see this post:

https://www.solarstrike.net/phpBB3/vie ... ix#p66393

User avatar
Administrator
Site Admin
Posts: 5083
Joined: Sat Jan 05, 2008 4:21 pm

Re: Version 7.4.0.2897 progress

#759 Post by Administrator » Thu Sep 24, 2020 8:47 pm

Sorry, I've been unavailable for the last week.

nuk79: I took a look at the script you posted and I think I've got a quick fix for this. I basically just repurposed similar code out of the speedhack, but have not tested it myself. Please try the attached script and let me know if it works.
JuiceDelivery.xml
(7.09 KiB) Downloaded 20 times
silentz wrote: Tue Sep 22, 2020 4:37 am Admin, can you look into this skill?

Warrior/Mage - WARRIOR_LIGHTNING_BURN_WEAPON

I have it in my profile and it would not cast this skill and doesn't say any error as if the skill is not there.



Thanks
Sorry, the elite and higher level skills are a huge pain for me to do any testing on since I don't have any characters that meet the requirements. I really wish I had a better solution to this, but if you're willing to let me borrow your account briefly then I could probably figure it out.

nuk79
Posts: 409
Joined: Mon May 17, 2010 3:40 pm

Re: Version 7.4.0.2897 progress

#760 Post by nuk79 » Fri Sep 25, 2020 3:45 am

Administrator wrote: Thu Sep 24, 2020 8:47 pm Sorry, I've been unavailable for the last week.

nuk79: I took a look at the script you posted and I think I've got a quick fix for this. I basically just repurposed similar code out of the speedhack, but have not tested it myself. Please try the attached script and let me know if it works.
JuiceDelivery.xml

silentz wrote: Tue Sep 22, 2020 4:37 am Admin, can you look into this skill?

Warrior/Mage - WARRIOR_LIGHTNING_BURN_WEAPON

I have it in my profile and it would not cast this skill and doesn't say any error as if the skill is not there.



Thanks
Sorry, the elite and higher level skills are a huge pain for me to do any testing on since I don't have any characters that meet the requirements. I really wish I had a better solution to this, but if you're willing to let me borrow your account briefly then I could probably figure it out.
this is the juice festival event which is located in tergotten, you just need to get there and test it at level 1 too :), cmq it doesn't matter you are always very kind :) I have another question:
1-how to kick offline ppl in party with simple command
2-how can i add at start from bot "/z or /s +word" for autoinvite when dailies up or say to bot click on macro in 1 position of bar
3- how to say to bot leave party when 10 dailies are finish and log out

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 28 guests